caml-list - the Caml user's mailing list
 help / Atom feed
* [Caml-list] opam install postgresql fail on 4.06.1 and 4.07.0
@ 2018-07-17 22:30 Casey Basichis
  2018-07-18  0:11 ` Thad Meyer
  0 siblings, 1 reply; 4+ messages in thread
From: Casey Basichis @ 2018-07-17 22:30 UTC (permalink / raw)
  To: OCaml Mailing List

[-- Attachment #1: Type: text/plain, Size: 2192 bytes --]

Any ideas what might be sparking?

This is a new mint 19 system.  The test below is the opam install output
and a psql test.  I also tried installing a pinned version from the github
repo with the same error.


=-=- Gathering sources
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
[postgresql] Archive in cache

=-=- Processing actions
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
[ERROR] The compilation of postgresql failed at "jbuilder build -p
postgresql -j 4".

#=== ERROR while installing postgresql.4.4.0
==================================#
# opam-version 1.2.2
# os           linux
# command      jbuilder build -p postgresql -j 4
# path         /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0
# compiler     4.07.0
# exit-code    1
# env-file
 /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.env
# stdout-file
/home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.out
# stderr-file
/home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.err
### stderr ###
# -> stdout:
# [...]
#  | cmxa_magic_number: Caml1999Z023
#  | ast_impl_magic_number: Caml1999M023
#  | ast_intf_magic_number: Caml1999N023
#  | cmxs_magic_number: Caml1999D023
#  | cmt_magic_number: Caml1999T023
# -> stderr:
# Fatal error: exception End_of_file
# Raised at file "src/configurator.ml", line 511, characters 13-22
# Called from file "src/config/discover.ml", line 6, characters 2-1023



=-=- Error report
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
The following actions failed
  ∗  install postgresql 4.4.0
No changes have been performed

=-=- postgresql.4.4.0 troobleshooting
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
=> This package relies on external (system) dependencies that may be
missing. `opam depext postgresql.4.4.0' may help
   you find the correct installation for your system.

-- 
Caml-list mailing list.  Subscription management and archives:
https://sympa.inria.fr/sympa/arc/caml-list
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners
Bug reports: http://caml.inria.fr/bin/caml-bugs

[-- Attachment #2: Type: text/html, Size: 2598 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [Caml-list] opam install postgresql fail on 4.06.1 and 4.07.0
  2018-07-17 22:30 [Caml-list] opam install postgresql fail on 4.06.1 and 4.07.0 Casey Basichis
@ 2018-07-18  0:11 ` Thad Meyer
  2018-07-18  0:15   ` Casey Basichis
  0 siblings, 1 reply; 4+ messages in thread
From: Thad Meyer @ 2018-07-18  0:11 UTC (permalink / raw)
  To: Casey Basichis; +Cc: OCaml Mailing List, caml-list-request

Hi Casey,

Could it be you're missing some system libraries or programs?

The last line of your error suggests executing this command:

opam depext postgresql.4.4.0

May provide a clue...can you let us know what the output is?

Happy Hacking

T


On 2018-07-17 17:30, Casey Basichis wrote:
> Any ideas what might be sparking?
> 
> This is a new mint 19 system.  The test below is the opam install
> output and a psql test.  I also tried installing a pinned version from
> the github repo with the same error.
> 
> =-=- Gathering sources
> =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> [postgresql] Archive in cache
> 
> =-=- Processing actions
> -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> [ERROR] The compilation of postgresql failed at "jbuilder build -p
> postgresql -j 4".
> 
> #=== ERROR while installing postgresql.4.4.0
> ==================================#
> # opam-version 1.2.2
> # os           linux
> # command      jbuilder build -p postgresql -j 4
> # path         /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0
> # compiler     4.07.0
> # exit-code    1
> # env-file
> /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.env
> # stdout-file
> /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.out
> # stderr-file
> /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.err
> ### stderr ###
> # -> stdout:
> # [...]
> #  | cmxa_magic_number: Caml1999Z023
> #  | ast_impl_magic_number: Caml1999M023
> #  | ast_intf_magic_number: Caml1999N023
> #  | cmxs_magic_number: Caml1999D023
> #  | cmt_magic_number: Caml1999T023
> # -> stderr:
> # Fatal error: exception End_of_file
> # Raised at file "src/configurator.ml [1]", line 511, characters 13-22
> # Called from file "src/config/discover.ml [2]", line 6, characters
> 2-1023
> 
> =-=- Error report
> -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> The following actions failed
>   ∗  install postgresql 4.4.0
> No changes have been performed
> 
> =-=- postgresql.4.4.0 troobleshooting
> -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> => This package relies on external (system) dependencies that may be
> missing. `opam depext postgresql.4.4.0' may help
>    you find the correct installation for your system.
> 
> 
> 
> Links:
> ------
> [1] http://configurator.ml
> [2] http://discover.ml


-- 
Caml-list mailing list.  Subscription management and archives:
https://sympa.inria.fr/sympa/arc/caml-list
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners
Bug reports: http://caml.inria.fr/bin/caml-bugs

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [Caml-list] opam install postgresql fail on 4.06.1 and 4.07.0
  2018-07-18  0:11 ` Thad Meyer
@ 2018-07-18  0:15   ` Casey Basichis
  2018-07-18  0:37     ` Markus Mottl
  0 siblings, 1 reply; 4+ messages in thread
From: Casey Basichis @ 2018-07-18  0:15 UTC (permalink / raw)
  To: tmeyer, OCaml Mailing List

[-- Attachment #1: Type: text/plain, Size: 3226 bytes --]

Hi Thad,

It could be a missing library.  Its a fresh install.  psql seems to run
(you can see in the original log text)

opam depext postgresql.4.4.0
# Detecting depexts using flags: x86_64 linux linuxmint
# No extra OS packages requirements found.

Is there something else I can check?

On Tue, Jul 17, 2018 at 5:11 PM Thad Meyer <tmeyer@members.fsf.org> wrote:

> Hi Casey,
>
> Could it be you're missing some system libraries or programs?
>
> The last line of your error suggests executing this command:
>
> opam depext postgresql.4.4.0
>
> May provide a clue...can you let us know what the output is?
>
> Happy Hacking
>
> T
>
>
> On 2018-07-17 17:30, Casey Basichis wrote:
> > Any ideas what might be sparking?
> >
> > This is a new mint 19 system.  The test below is the opam install
> > output and a psql test.  I also tried installing a pinned version from
> > the github repo with the same error.
> >
> > =-=- Gathering sources
> > =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> > [postgresql] Archive in cache
> >
> > =-=- Processing actions
> > -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> > [ERROR] The compilation of postgresql failed at "jbuilder build -p
> > postgresql -j 4".
> >
> > #=== ERROR while installing postgresql.4.4.0
> > ==================================#
> > # opam-version 1.2.2
> > # os           linux
> > # command      jbuilder build -p postgresql -j 4
> > # path         /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0
> > # compiler     4.07.0
> > # exit-code    1
> > # env-file
> >
> /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.env
> > # stdout-file
> >
> /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.out
> > # stderr-file
> >
> /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.err
> > ### stderr ###
> > # -> stdout:
> > # [...]
> > #  | cmxa_magic_number: Caml1999Z023
> > #  | ast_impl_magic_number: Caml1999M023
> > #  | ast_intf_magic_number: Caml1999N023
> > #  | cmxs_magic_number: Caml1999D023
> > #  | cmt_magic_number: Caml1999T023
> > # -> stderr:
> > # Fatal error: exception End_of_file
> > # Raised at file "src/configurator.ml [1]", line 511, characters 13-22
> > # Called from file "src/config/discover.ml [2]", line 6, characters
> > 2-1023
> >
> > =-=- Error report
> > -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> > The following actions failed
> >   ∗  install postgresql 4.4.0
> > No changes have been performed
> >
> > =-=- postgresql.4.4.0 troobleshooting
> > -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> > => This package relies on external (system) dependencies that may be
> > missing. `opam depext postgresql.4.4.0' may help
> >    you find the correct installation for your system.
> >
> >
> >
> > Links:
> > ------
> > [1] http://configurator.ml
> > [2] http://discover.ml
>
>

-- 
Caml-list mailing list.  Subscription management and archives:
https://sympa.inria.fr/sympa/arc/caml-list
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners
Bug reports: http://caml.inria.fr/bin/caml-bugs

[-- Attachment #2: Type: text/html, Size: 4031 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [Caml-list] opam install postgresql fail on 4.06.1 and 4.07.0
  2018-07-18  0:15   ` Casey Basichis
@ 2018-07-18  0:37     ` Markus Mottl
  0 siblings, 0 replies; 4+ messages in thread
From: Markus Mottl @ 2018-07-18  0:37 UTC (permalink / raw)
  To: Casey Basichis; +Cc: tmeyer, OCaml List

[-- Attachment #1: Type: text/plain, Size: 3620 bytes --]

Problem solved via client C-library installation:
https://github.com/mmottl/postgresql-ocaml/issues/28

Regards,
Markus

On Tue, Jul 17, 2018 at 8:15 PM Casey Basichis <caseybasichis@gmail.com>
wrote:

> Hi Thad,
>
> It could be a missing library.  Its a fresh install.  psql seems to run
> (you can see in the original log text)
>
> opam depext postgresql.4.4.0
> # Detecting depexts using flags: x86_64 linux linuxmint
> # No extra OS packages requirements found.
>
> Is there something else I can check?
>
> On Tue, Jul 17, 2018 at 5:11 PM Thad Meyer <tmeyer@members.fsf.org> wrote:
>
>> Hi Casey,
>>
>> Could it be you're missing some system libraries or programs?
>>
>> The last line of your error suggests executing this command:
>>
>> opam depext postgresql.4.4.0
>>
>> May provide a clue...can you let us know what the output is?
>>
>> Happy Hacking
>>
>> T
>>
>>
>> On 2018-07-17 17:30, Casey Basichis wrote:
>> > Any ideas what might be sparking?
>> >
>> > This is a new mint 19 system.  The test below is the opam install
>> > output and a psql test.  I also tried installing a pinned version from
>> > the github repo with the same error.
>> >
>> > =-=- Gathering sources
>> > =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
>> > [postgresql] Archive in cache
>> >
>> > =-=- Processing actions
>> > -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
>> > [ERROR] The compilation of postgresql failed at "jbuilder build -p
>> > postgresql -j 4".
>> >
>> > #=== ERROR while installing postgresql.4.4.0
>> > ==================================#
>> > # opam-version 1.2.2
>> > # os           linux
>> > # command      jbuilder build -p postgresql -j 4
>> > # path         /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0
>> > # compiler     4.07.0
>> > # exit-code    1
>> > # env-file
>> >
>> /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.env
>> > # stdout-file
>> >
>> /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.out
>> > # stderr-file
>> >
>> /home/caseybasichis/.opam/4.07.0/build/postgresql.4.4.0/postgresql-16795-5f1023.err
>> > ### stderr ###
>> > # -> stdout:
>> > # [...]
>> > #  | cmxa_magic_number: Caml1999Z023
>> > #  | ast_impl_magic_number: Caml1999M023
>> > #  | ast_intf_magic_number: Caml1999N023
>> > #  | cmxs_magic_number: Caml1999D023
>> > #  | cmt_magic_number: Caml1999T023
>> > # -> stderr:
>> > # Fatal error: exception End_of_file
>> > # Raised at file "src/configurator.ml [1]", line 511, characters 13-22
>> > # Called from file "src/config/discover.ml [2]", line 6, characters
>> > 2-1023
>> >
>> > =-=- Error report
>> > -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
>> > The following actions failed
>> >   ∗  install postgresql 4.4.0
>> > No changes have been performed
>> >
>> > =-=- postgresql.4.4.0 troobleshooting
>> > -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
>> > => This package relies on external (system) dependencies that may be
>> > missing. `opam depext postgresql.4.4.0' may help
>> >    you find the correct installation for your system.
>> >
>> >
>> >
>> > Links:
>> > ------
>> > [1] http://configurator.ml
>> > [2] http://discover.ml
>>
>>

-- 
Markus Mottl        http://www.ocaml.info        markus.mottl@gmail.com

-- 
Caml-list mailing list.  Subscription management and archives:
https://sympa.inria.fr/sympa/arc/caml-list
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners
Bug reports: http://caml.inria.fr/bin/caml-bugs

[-- Attachment #2: Type: text/html, Size: 4885 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, back to index

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-07-17 22:30 [Caml-list] opam install postgresql fail on 4.06.1 and 4.07.0 Casey Basichis
2018-07-18  0:11 ` Thad Meyer
2018-07-18  0:15   ` Casey Basichis
2018-07-18  0:37     ` Markus Mottl

caml-list - the Caml user's mailing list

Archives are clonable: git clone --mirror https://inbox.ocaml.org/caml-list

AGPL code for this site: git clone https://public-inbox.org/ public-inbox