caml-list - the Caml user's mailing list
 help / Atom feed
From: "David Allsopp" <dra-news@metastack.com>
To: "'François Pottier'" <francois.pottier@inria.fr>, "Jeremie Dimino" <jdimino@janestreet.com>
Cc: "caml users" <caml-list@inria.fr>
Subject: RE: [Caml-list] dune for OCaml < 4.07?
Date: Mon, 10 Feb 2020 11:18:59 +0100
Message-ID: <002401d5dffb$848f0b10$8dad2130$@metastack.com> (raw)
In-Reply-To: <d0654354-ddbb-575f-a892-b2a56a84cd4a@inria.fr>

François Pottier wrote:
> On 06/02/2020 23:33, Jeremie Dimino wrote:
> > We just submitted the release of Dune 2.2.0:
> > https://github.com/ocaml/opam-repository/pull/15795
> 
> Thanks Jérémie. This seems to work great.
> 
> However, I realize that recent versions of dune require OCaml 4.07.
> Menhir is supposed to be compatible with OCaml all the way back to 4.02.3.
> Is there any way to install dune 2.2.0 with OCaml < 4.07?

TL;DR for installing Menhir on OCaml 4.02-4.06 using opam, you don't need to do anything.

Dune 2.0.0+ requires at least OCaml 4.07 to build, but the dune package in opam does not. More detail in case it's relevant to be able to do that without opam...

For OCaml 4.02-4.06, Dune depends on the ocaml-secondary-compiler package[1], which installs a separate copy of OCaml 4.08.1 in your switch which is accessed using `ocamlfind -toolchain secondary` and that's configured in the ocamlfind-secondary package. Dune's bootstrap natively looks for the ocamlfind secondary toolchain if the OCaml version is < 4.07, so opam is not required, you just have to configure ocamlfind manually if not using it. So installing without opam requires building (or having) a later of version of OCaml in a different path, and then creating the configuration file for ocamlfind so that it can use it.

HTH,


David


[1] https://github.com/ocaml/opam-repository/tree/master/packages/ocaml-secondary-compiler/ocaml-secondary-compiler.4.08.1
[2] https://github.com/ocaml/opam-repository/tree/master/packages/ocamlfind-secondary/ocamlfind-secondary.1.8.1


  reply index

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-31  8:49 [Caml-list] (dune/opam) Proper way of vendoring a library inside an application? François Pottier
2020-01-31 13:08 ` François Bobot
2020-01-31 14:53   ` François Pottier
2020-02-03 10:27 ` Jeremie Dimino
2020-02-03 14:17   ` Jeremie Dimino
2020-02-03 14:53     ` François Pottier
2020-02-03 23:13       ` Jeremie Dimino
2020-02-04  9:11         ` François Pottier
2020-02-06 22:33           ` Jeremie Dimino
2020-02-10  9:37             ` [Caml-list] dune for OCaml < 4.07? François Pottier
2020-02-10 10:19               ` David Allsopp [this message]
2020-02-10 10:33                 ` François Pottier
2020-02-10 11:27                   ` David Allsopp
2020-02-29  8:41 ` [Caml-list] (dune/opam) Proper way of vendoring a library inside an application? Richard W.M. Jones
2020-02-29 11:20   ` François Pottier
2020-03-02  9:33     ` François Bobot

Reply instructions:

You may reply publically to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='002401d5dffb$848f0b10$8dad2130$@metastack.com' \
    --to=dra-news@metastack.com \
    --cc=caml-list@inria.fr \
    --cc=francois.pottier@inria.fr \
    --cc=jdimino@janestreet.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

caml-list - the Caml user's mailing list

Archives are clonable: git clone --mirror https://inbox.ocaml.org/caml-list

AGPL code for this site: git clone https://public-inbox.org/ public-inbox